覚え書きブログ

読者です 読者をやめる 読者になる 読者になる

Deep Learning覚え書き(TensorflowのWindows版0.12rc1のインストール)

前回インストールしたWindows版のTensorflow0.12rc0では、tensorboardが正しく動かない(ブラウザからアクセスするとwebcomponentsjsがnot found)問題があった。その後リリースされた0.12rc1ではTensorboardの問題が解消されているらしいので早速インストールしてみた。
hirotaka-hachiya.hatenablog.com

しかしながら、下記のマニュアルのpip先が0.12rc0から0.12rc1に変わったものの、実際にはstorage.googleapis.comにまだアップロードされていないようで(2016年12/14時点)、下記のような404(not found)エラーがでる。
https://www.tensorflow.org/get_started/os_setup#pip-installation-on-windows

>pip install --upgrade --ignore-installed https://storage.googleapis.com/tensorflow/windows/gpu/tensorflow_gpu-0.12.0rc1-cp35-cp35m-win_amd64.whl
Collecting tensorflow-gpu==0.12.0rc1 from https://storage.googleapis.com/tensorflow/windows/gpu/tensorflow_gpu-0.12.0rc1-cp35-cp35m-win_amd64.whl
  HTTP error 404 while getting 

そこで、今回は、アップロードされている下記のpythonのサイトから「tensorflow-0.12.0rc1-cp35-cp35m-win_amd64.whl」をダウンロードして自分でインストールしてみた。
https://pypi.python.org/pypi/tensorflow

>pip install tensorflow-0.12.0rc1-cp35-cp35m-win_amd64.whl
Processing c:\users\pc user\documents\deeplearning\tensorflow\tensorflow-0.12.0rc1-cp35-cp35m-win_amd64.whl
Requirement already satisfied (use --upgrade to upgrade): six>=1.10.0 in c:\program files\anaconda3\lib\site-packages (from tensorflow==0.12.0rc1)
Requirement already satisfied (use --upgrade to upgrade): wheel>=0.26 in c:\program files\anaconda3\lib\site-packages (from tensorflow==0.12.0rc1)
Requirement already satisfied (use --upgrade to upgrade): protobuf==3.1.0 in c:\program files\anaconda3\lib\site-packages (from tensorflow==0.12.0rc1)
Requirement already satisfied (use --upgrade to upgrade): numpy>=1.11.0 in c:\program files\anaconda3\lib\site-packages (from tensorflow==0.12.0rc1)
Requirement already satisfied (use --upgrade to upgrade): setuptools in c:\program files\anaconda3\lib\site-packages (from protobuf==3.1.0->tensorflow==0.12.0rc1)
Installing collected packages: tensorflow
Successfully installed tensorflow-0.12.0rc1

そして、下記のようにtensorboardを起動しブラウザでlocalhost:6006にアクセスしてみた。

>tensorboard --logdir=C:\tmp\mnist_logs
Starting TensorBoard b'39' on port 6006
(You can navigate to http://192.168.11.6:6006)

f:id:hirotaka_hachiya:20161214182738p:plain
見事にtensorboardが動作していることが確認できた。グラフや入力画像の表示はこんな感じ。
f:id:hirotaka_hachiya:20161214182936p:plain
f:id:hirotaka_hachiya:20161214183151p:plain