覚え書きブログ

読者です 読者をやめる 読者になる 読者になる

Ubuntuの覚え書き(flash playerプラグインのインストール編)

Ubuntu14.04のMozilla FirefoxFlash playerのプラグラインを入れてみた。
まず、下記のAdobeFlash playerのダウンロードサイトにアクセスしてみたが、Ubuntu用のパッケージ(debファイル)が見当たらない。
https://get2.adobe.com/jp/flashplayer/

そこで、apt-cacheで以下のように探してみた。

> apt-cache search adobe flash
texlive-latex-extra - TeX Live: LaTeX additional packages
flashplugin-installer - Adobe Flash Player plugin installer
flashplugin-downloader - Adobe Flash Player plugin installer (transitional package)
flashplugin-nonfree-extrasound - Adobe Flash Player platform support library for Esound and OSS
bleachbit - delete unnecessary files from the system
cclive - lightweight command line video extraction tool
libjs-swfobject - tool to embed Flash content into webpages
libquvi-dev - library for parsing video download links (development package)
libquvi-doc - library for parsing video download links (documentation package)
libquvi-scripts - library for parsing video download links (Lua scripts)
libquvi7 - library for parsing video download links (runtime libraries)
libvdpau-va-gl1 - VDPAU driver with OpenGL/VAAPI backend
nomnom - download videos from Youtube and other similar video websites
quvi - command line program to extract video download links
red5-doc - flash streaming server - documentation
red5-server - flash streaming server
konqueror-nsplugins - Netscape plugin support for Konqueror

flashplugin-installerという、それらしきものがあったので、インストールしてみたところ、下記のように、adobe-flashplugin_11.2.202.451.orig.tar.gzをダウンロードしてインストールしてくれた。

> sudo apt-get install flashplugin-installer
Preparing to unpack .../flashplugin-installer_11.2.202.451ubuntu0.14.04.1_amd64.deb ...
Unpacking flashplugin-installer (11.2.202.451ubuntu0.14.04.1) ...
Processing triggers for update-notifier-common (0.154.1ubuntu1) ...
flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.451.orig.tar.gz
Installing from local file /tmp/tmpHCLRfm.gz
Flash Plugin installed.
flashplugin-installer (11.2.202.451ubuntu0.14.04.1) を設定しています ...

Flash playerプラグインが動作しているか否かは、下記のページで確認することができる。
https://helpx.adobe.com/jp/flash-player/kb/235703.html